Pending Transaction

Please see this tweet here explaining the bridge:

1 Like

Hello, can any of the dev help out. I did a swap on echodex from ETH to Linea WETH and am yet to receive the value . It been confirmed that the Eth was successfully deposited into the Linea WETH contract address but the WETH value is yet to be sent to my wallet since over an hour now.

Here is the transaction hash: 0x54ffa4bfcb4e075fcf924662c77f43d928ab9ab3168e48bc2a2d9cdeb5ae6d13

Thanks in anticipation

Hey @user1330, tokens should not be deposited directly into a contract address. I would reach out to the echodex team about this

2 Likes

Hi, I have a problem with Pending transaction in Metamask , but no match in lineascan !
This is an approval for ECP token, it said Pending in Metamask, for a few days now. But no match in Lineascan when I tried to track it down.
:

I tried new transactions , but they all fail.

Please help!
Thanks?

Hi, I can’t complete this transaction. I increased the GWEI to 26, which is 10 times higher than the current value, but the transaction still fails to go through. I’ve been unable to make a transaction from my wallet for 5 days. Initially, I faced the same issue as the person above, where all transactions made through Metamask resulted in errors. I downloaded the Rabby wallet and tried to perform a transaction through it. The result is as mentioned above: with GWEI set to 26, the transaction still can’t proceed.

It tooks almost 4 minutes to complete a transaction. Is it normal?

1 Like

Hi @vann -

It’s most likely due to gas being too low on transaction when submitted. To fix this, you can try to wait or cancel the pending transaction trying the following method:

Cancel the transaction that is stuck in MetaMask under your Activity Tab. When you do this, you will need to follow the steps below:

  • If you have multiple pending transactions, start with oldest first
  • hit “cancel” button in MetaMask
  • on page with gas cost, hitting the “market” button that will load
  • choose “advanced” (this is very important)
  • manually adjust both the Max Fee per Gas and Max Priority Fee to be slightly higher than what showing on the **gas tracker **on here: https://explorer.linea.build/ ,

After you do above - and transaction is cancelled, you can try the transaction again. BUT FIRST always adjust your gas using the advanced setting option in MetaMask before sending transaction. You want to match the gwei number to always match what is under gas tracker here: https://explorer.linea.build/

This will be fixed, you won’t always have to do this, but for now it will help avoid stuck transactions.

If this does not work, please reach out here: https://support.linea.build/hc/en-us/requests/new

Hi @Denny -

Try to cancel through custom nonce.

This article shares these steps :

If this does not work, please reach out here: https://support.linea.build/hc/en-us/requests/new

Hi @zorzenon -

No, this is not normal. It might be due to gas fees not loading accurately / high enough on MetaMask.

You can adjust the gas to be what is the current gas on network:

To do this:

  • In MetaMask on page with gas cost, select the “market” button above where your gas fee shows
  • choose “advanced” (this is very important)
  • manually adjust both the Max Fee per Gas and Max Priority Fee to match the gwei what showing on the gas tracker on here: https://explorer.linea.build/ ,

Thanks. I already tried all the above. The lineascan seems clear, without any pending tx. But all new txs are failing now, none will go thru and none shows status on lineascan. I want to try to delete Linea chain, and re-add, but cant do that in Metamask.
I will file a support ticket, since all my funds is stuck!
Again thanks.

Hello, I have a pending tx on the Linea network, it’s a pb with the USDC Circle contract on Linea. I tried to cancel the tx by making a new tx with the same nonce but it doesn’t work. I don’t know what to do. If anyone can help me, please.

my adress : 0x5334aeA575C8bCCfeA58E489D9117EbdFbceA64e

Read the article link published by KBeeTheCapybara above, strictly follow its steps, there are many places to pay attention to. You should be able to succeed.

1 Like